Update bei pfSense schlägt fehl

  • -

Update bei pfSense schlägt fehl

Bei dem Update der pfSense z. B. auf die Version 2.3.2 kann es derzeit zu Problemen des Updates kommen.
Dabei wird das Update zwar ausgeführt jedoch fährt die pfSense dann nicht mehr richtig hoch.

Grund dafür ist die Fehlermeldung can’t load ‚kernel‘.

Das Problem bei dem Update über die GUI ist im eigentlichen also kein Problem von der pfSense Software sondern von dem Linux Kernel der darunter läuft.

Damit wir das Update erfolgreich durchgeführt bekommen machen wir die Prozedur per Hand.

Dabei sollte der Proxy und die Carp Verbindung um Fehler zu vermeiden getrennt sein für die Dauer der Prozedur.

Dazu Loggen wir uns per SSH auf der pfSense als admin ein und gehen mit der 8 in die Konsole.
pfsense

Dort starten wir mit dem Befehl pkg update –f das Updaten der Repositories.

pfsense
Wenn dies ausgeführt wurde starten wir mit pkg upgrade –f das Upgrade auf das aktuelle System.
Dabei werden auch die Pakete wie php, curl, mcrypt etc. mit aktualisiert.

pfsense-update_5

Dies dauert dann einige Minuten je nach Internetverbindung.

Der Parameter –f versucht die Fehler direkt zu beheben.
Manche Sachen müssen mit y oder j bestätigt werden für die Installation. Dies einfach mit „y und der Eingabetaste“ bestätigen.

Damit der Kernel direkt auch installiert wird führen wir nun das Update der pfSense aus.
Das update wird mit pfSense-upgrade –d ausgeführt und updatet das komplette System.
Nach Beendigung von dem Upgrade Vorgang wird das System neu gestartet.

pfsense-update_4

Ab jetzt läuft auf der pfSense das aktuellste System in dem Fall dann die Version 2.3.2_r1

pfsense-update_7

Wir wünschen viel Erfolg

Share

Share